Całkowicie nowy poziom usług hostingowych: superszybkie serwery, 14 dni bez zobowiązań, darmowa migracja - zenbox.pl

Funkcja ORAZ – podstawy

Funkcja ORAZ – podstawy
Doczego służy funkcja ORAZ?

Funkcją ORAZ sprawdzimy prawdziwość dwóch lub więcej raunków.

Funkcja ORAZ – jak jest zbudowana?

Funkcja ORAZ musi posiadać przynajmniej jeden argument, ale sensowniej jest użyć conajmniej dwóch argumentów – ORAZ(A1=2;A2=2) – funkcja w takim przypadku zróci PRAWDĘ, jeśli obudwa warunki zostały spełnine, czyli zarówno komórka A1 jak i A2 równe są 2.

Zapisz się do newslettera

Zapisz się do newslettera lubieExcela.pl
bądź zawsze na bieżąco

Funkcja ORAZ – podstawowe wykorzystanie

Pamiętam, że pierwszą funkcję jaką poznalem w Excelu była funkcja JEŻELI. Namiętnie z niej korzystałem i wiem, że jeśli się wysilimy to możemy ją wykorzystywać w kilku zagnieżdżeniach. Wtedy można było zagnieździć funkcję JEŻELI maksymalne 7 razy –  moim zdaniem to już było nadto. Jeśli zdarzy się więc przypadek, że będziecie chcieli sprawdzić prawdziwość kilku warunków to skorzystajcie własnie z tej funkcji. A jak z niej skorzystać? Poniżej jej skladnia:
=JEŻELI(warunek=prawda;JEŻELI(warunek=prawda;JEŻELI(warunek=prawda;
wartość_jeśli_prawda;wartość_jeśli_fałsz)))

No, ale mowa miała być o innej funkcji, więc jeśli jeszcze nie znacie funkcji ORAZ() to proszę zapoznajcie się z nią, jest bardzo przydatna, kiedy w funkcji JEŻELI() chcemy sprawdzić czy conajmnijej 2 argumenty są prawdziwe lub nie.

Budowa funkcji ORAZ()

Funkcja ORAZ jest bardzo prosta w budowie, po nazwie podajemy warunki i jeśli wszystkie są prawdziwe zwraca wartość PRAWDA, jeśli jeden nie jest prawdziwy zwraca FAŁSZ ORAZ(warunek_logiczny;warunek_logiczy2;warunek_logiczny3;[…]warunek_logicznyN)

Wracając do wcześniejszego przedstawienia jak wyglądałaby funkcja JEŻELI:
=JEŻELI(warunek=prawda;JEŻELI(warunek=prawda;JEŻELI(warunek=prawda;
wartość_jeśli_prawda;wartość_jeśli_fałsz)))

A jak ORAZ:

=JEŻELI(ORAZ(warunek=prawda; warunek=prawda; warunek=prawda); wartość_jeśli_prawda;wartość_jeśli_fałsz)

Praca z przykładowym plikiem

Skoro znamy już składnię funkcji ORAZ, to możemy zacząć pracować na jakimś przykładzie. Plik do przykładu można pobrać poniżej.

Plik do ORAZ – podstawy

UWAGA! Plik wyświetla błędy, jeśli wpisana funkcja w komórkę jest inna niż zaplanowałem dla danego przykładu. Co nie oznacza, że koniecznie jest to błędem, ponieważ często pewne rzeczy w Excelu można zrobić na kilka / kilkanaście sposobów..

Funkcja ORAZ w przykładzie

Wykorzystajmy funkcję ORAZ, by sprawdzić czy możemy wystawić fakturę

Fakturę możemy wystawić, jeśli  projekt został wysłany do akceptacji, został zaakceptowany oraz zakończony.

Excel - ORAZ

Zacznijmy więc od funkcji ORAZ, w komórce F8 wpiszmy: =ORAZ(C8=”TAK”;D8=”TAK”;E8=”TAK”)

Excel funkcja ORAZ z argumentami

Funkcja sprawdzi, czy wszystkie zawarte w niej warunki są prawdzie, jeśli tak to wypisze PRAWDA. Nie przejmujcie się komunikatem  W formule jest błąd!, chyba, że zakończyliście zadanie i nadal się pojawia, oznaczać będzie, że zadanie nie zostało wykonane dokładnie tak jak w opisanym przykładzie.

Excel - ORAZ - błąd w formule

Dodajmy funkcję JEŻELI, by wyświetliła odpowiedni komunikat

Teraz opakujmy naszą funkcje ORAZ w funkcje JEŻELI, by można było wyświetlić: TAK lub NIE, w zależności od tego, czy wszystkie warunki są prawdziwe, czy tez nie.

=JEŻELI(ORAZ(C8=”TAK”;D8=”TAK”;E8=”TAK”);”TAK”;”NIE”)

Excel -funkcja JEŻELI

Po zatwierdzeniu klawiszem ENTER, kliknijmy na komórkę F8, następnie przesuńmy kursor w prawy dolny róg komórki aż zmieni się kształt kursora w czarny krzyżyk, a wtedy dwa razy kliknijmy lewym przyciskiem myszy.

Kopiowanie formuły z funkcją ORAZ

Formatowanie warunkowe – bonus

To może, by wynik był bardziej czytelny dodajmy formatowanie warunkowe. Zaznaczmy obszar F8:F13:

  1. Wstążka karta Narzędzia główne, Formatowanie warunkowe
  2. Reguły wyróżniania komórek
  3. Tekst zawierający…
  4. Wpiszmy TAK i wybierzmy Zielone wypełnienie z ciemnozielonym tekstem i naciskamy OK
  5. Ponawiamy kroki 1 do 4, a w punkcie 4 wpisujemy NIE i wybieramy Jasnoczerwone wypełnienie z ciemnozielonym tekstem i naciskamy OK
Excel - formatowanie warunkowe

Jeśli wszystko wykonaliśmy dobrze to poniżej mamy wynik gotowego zadania.

Excel zakończone zadanie z funkcji ORAZ, JEŻELI

Zobacz inne przykłady

Jeśli spodobał Ci się wpis pozostaw po sobie znak w formie komentarza, a także zapraszam do zapisania się na moją listę mailingową. Przy okazji może zainteresują Cię inne moje artykuły.

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Wymagane pola są oznaczone *

Witryna wykorzystuje Akismet, aby ograniczyć spam. Dowiedz się więcej jak przetwarzane są dane komentarzy.